<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<title>Homecoming Rundown 2017: Welcome to the Circus! - The Houstonian</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta http-equiv="cleartype" content="on">
<meta name="HandheldFriendly" content="True">
<meta property="twitter:account_id" content="111508104" />
<meta name="twitter:card" content="summary_large_image">
<link rel="shortcut icon" href="http://houstonianonline.com/favicon.ico">
<meta name="revised" content="Wednesday, October 18, 2017, 12:39 pm" />


<link rel="canonical" href="http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Homecoming Rundown 2017: Welcome to the Circus! - The Houstonian" />
<meta property="og:description" content="Homecoming is here! Today marks the first day of festivities for Sam Houston State University’s Homecoming celebration, “Sammy’s Circus”. The theme was voted on last April as part of the SGA elections, and Bearkats Under the Big Top won by a landslide. Ringmaster Sammy has spent the last few months lining up festivities, and they &hellip;" />
<meta property="og:url" content="http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/" />
<meta property="og:site_name" content="The Houstonian" />
<meta property="article:publisher" content="https://www.facebook.com/HoustonianSHSU" />
<meta property="article:tag" content="Featured" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2017-10-18T12:39:21-05:00" />
<meta property="og:image" content="http://houstonianonline.com/wp-content/uploads/2017/10/Homecoming-2009-127.jpg" />
<meta property="og:image:width" content="2954" />
<meta property="og:image:height" content="2085" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Homecoming is here! Today marks the first day of festivities for Sam Houston State University’s Homecoming celebration, “Sammy’s Circus”. The theme was voted on last April as part of the SGA elections, and Bearkats Under the Big Top won by a landslide. Ringmaster Sammy has spent the last few months lining up festivities, and they [&hellip;]" />
<meta name="twitter:title" content="Homecoming Rundown 2017: Welcome to the Circus! - The Houstonian" />
<meta name="twitter:site" content="@HoustonianSHSU" />
<meta name="twitter:image" content="http://houstonianonline.com/wp-content/uploads/2017/10/Homecoming-2009-127.jpg" />
<meta name="twitter:creator" content="@HoustonianSHSU" />

<link rel="alternate" type="application/rss+xml" title="The Houstonian &raquo; Feed" href="http://houstonianonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Houstonian &raquo; Comments Feed" href="http://houstonianonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Houstonian &raquo; Homecoming Rundown 2017: Welcome to the Circus! Comments Feed" href="http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/houstonianonline.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css' href='http://houstonianonline.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css' href='http://houstonianonline.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='http://houstonianonline.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='http://houstonianonline.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='simple-instagram-public-styles-css' href='http://houstonianonline.com/wp-content/plugins/simple-instagram/public/assets/css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/foundation.css' type='text/css' media='all' />
<link rel='stylesheet' id='flex-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='app-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/app.css' type='text/css' media='all' />
<link rel='stylesheet' id='selection-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/selection.php?ModPagespeed=off' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='ie8-css'  href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/ie8.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mp-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/css/magnific-popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='style-css' href='http://houstonianonline.com/wp-content/themes/exquisite-wp-child/style.css' type='text/css' media='all' />
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/wp-a11y.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No search results.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate."};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"dad7976309","ajaxurl":"http:\/\/houstonianonline.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/wunderground/assets/js/widget.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/modernizr.foundation.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"","sampling_rate":"100","ajax_url":"http:\/\/houstonianonline.com\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"22318","token":"423422e63d"};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/wordpress-popular-posts/public/js/tracking.js'></script>
<link rel='https://api.w.org/' href='http://houstonianonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://houstonianonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://houstonianonline.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.5.10" />
<link rel='shortlink' href='http://houstonianonline.com/?p=22318' />
<link rel="alternate" type="application/json+oembed" href="http://houstonianonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fhoustonianonline.com%2F2017%2F10%2F18%2Fhomecoming-rundown-2017-welcome-circus%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://houstonianonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fhoustonianonline.com%2F2017%2F10%2F18%2Fhomecoming-rundown-2017-welcome-circus%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-4 {  margin: 0 auto; }
	.g-5 {  margin: 0 auto; }
	.g-16 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
.adrotate_widgets { overflow:hidden; padding:0; }
</style>

<style type="text/css" media="screen">
	#rotator {
		position: relative;
		width: 300px;
		height: 200px;
		margin: 0; padding: 0;
		overflow: hidden;
	}
</style>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="http://houstonianonline.com/wp-content/uploads/2014/08/icon_web-150x150.png" sizes="32x32" />
<link rel="icon" href="http://houstonianonline.com/wp-content/uploads/2014/08/icon_web-300x266.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://houstonianonline.com/wp-content/uploads/2014/08/icon_web-300x266.png" />
<meta name="msapplication-TileImage" content="http://houstonianonline.com/wp-content/uploads/2014/08/icon_web.png" />

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-75932824-1', 'auto');
  ga('send', 'pageview');
</script>

</head>
<body class="single single-post postid-22318 single-format-standard " data-url="http://houstonianonline.com">
<div id="wrapper">

<div id="subheader">
<div class="row">
<div class="six columns hide-for-medium-down">
<ul id="menu-top" class="sf-menu"><li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-25"><a href="http://houstonianonline.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://houstonianonline.com/privacy-policy/">Privacy</a></li>
</ul>
</li>
<li id="menu-item-274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-274"><a href="http://houstonianonline.com/advertising/">Advertise</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22"><a href="http://houstonianonline.com/contact/">Contact</a>
<ul class="sub-menu">
<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="http://houstonianonline.com/contribute/">Contribute</a></li>
</ul>
</li>
<li id="menu-item-2713" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2713"><a href="http://houstonianonline.com/current/">Current Issue</a>
<ul class="sub-menu">
<li id="menu-item-331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-331"><a href="http://houstonianonline.com/special-issues/">Special Issues</a>
<ul class="sub-menu">
<li id="menu-item-6259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6259"><a href="http://issuu.com/thehoustonian/docs/2014-orientation-issue">2014 Orientation Issue</a></li>
<li id="menu-item-18742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18742"><a href="https://issuu.com/thehoustonian/docs/houstonianorientationeditionreduced">2015 Orientation Issue</a></li>
<li id="menu-item-18890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18890"><a href="https://issuu.com/thehoustonian2016/docs/orientationedition2016-compressed">2016 Orientation Issue</a></li>
<li id="menu-item-21584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21584"><a href="https://issuu.com/thehoustonian2016/docs/all">2017 Orientation Issue</a></li>
</ul>
</li>
</ul>
</li>
</ul> </div>
<div class="six mobile-one columns show-for-medium-down">
<i class="fa fa-reorder" id="mobile-toggle"></i>
</div>
<div class="six mobile-three columns social">
<a href="https://www.facebook.com/HoustonianSHSU" class="boxed-icon facebook icon-1x rounded"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/HoustonianSHSU" class="boxed-icon twitter icon-1x rounded"><i class="fa fa-twitter"></i></a>
<a href="https://www.linkedin.com/company/783666?trk=tyah&trkInfo=tarId%3A1407520469915%2Ctas%3Athe%20houstonian%2Cidx%3A1-1-1" class="boxed-icon linkedin icon-1x rounded"><i class="fa fa-linkedin"></i></a>
<a href="https://www.instagram.com/houstonianshsu/" class="boxed-icon instagram icon-1x rounded"><i class="fa fa-instagram"></i></a>
<a href="https://www.youtube.com/user/HoustonianNews" class="boxed-icon tumblr icon-1x rounded"><i class="fa fa-youtube"></i></a>
</div>
</div>
</div>


<div id="mobile-menu">
<ul id="menu-top-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-25"><a href="http://houstonianonline.com/about/">About</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://houstonianonline.com/privacy-policy/">Privacy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-274"><a href="http://houstonianonline.com/advertising/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22"><a href="http://houstonianonline.com/contact/">Contact</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="http://houstonianonline.com/contribute/">Contribute</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2713"><a href="http://houstonianonline.com/current/">Current Issue</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-331"><a href="http://houstonianonline.com/special-issues/">Special Issues</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6259"><a href="http://issuu.com/thehoustonian/docs/2014-orientation-issue">2014 Orientation Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18742"><a href="https://issuu.com/thehoustonian/docs/houstonianorientationeditionreduced">2015 Orientation Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18890"><a href="https://issuu.com/thehoustonian2016/docs/orientationedition2016-compressed">2016 Orientation Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21584"><a href="https://issuu.com/thehoustonian2016/docs/all">2017 Orientation Issue</a></li>
</ul>
</li>
</ul>
</li>
</ul> </div>


<header id="header" class="style2">
<div class="row">
<div class="four columns logo">
<a href="http://houstonianonline.com"><img src="http://houstonianonline.com/wp-content/uploads/2014/08/web_logo.png" class="logoimg" alt="The Houstonian" /></a>
<br><time>October 19, 2017</time> </div>
<div class="eight columns">
<aside class="advertisement">
<div class="g g-1"><div class="g-single a-63"><a href="" onclick="var links = ['https://www.facebook.com/HoustonianSHSU/?fref=ts','https://www.facebook.com/houstonianadvertising/?fref=ts','https://twitter.com/HoustonianSHSU','https://twitter.com/houstonian_ads',
		'https://www.instagram.com/houstonianshsu/', 'https://www.instagram.com/houstonianadsanddeals/'];
		var num = Math.floor((Math.random() * 6));
		window.open(links[num]);"><img src="http://houstonianonline.com/wp-content/uploads/2014/08/socialMediaBannerAd.png" /></a></div></div></aside>
</div>
</div>
</header>


<div id="nav">
<div class="row">
<div class="twelve columns">
<nav>
<ul id="menu-home" class="mega-menu sf-menu"><li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="http://houstonianonline.com/category/news/">News</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="http://houstonianonline.com/category/sports/">Sports</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="http://houstonianonline.com/category/culture/">Campus Culture</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="http://houstonianonline.com/category/viewpoints/">Viewpoints</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="http://houstonianonline.com/category/multimedia/">Multimedia</a></li>
<li id="menu-item-18743" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18743"><a href="http://houstonianonline.com/useful-links/">Useful Links</a></li>
<li id="menu-item-17638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17638"><a href="http://houstonianonline.com/special-issues/">Orientation Edition</a></li>
<li id="menu-item-21062" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21062"><a href="https://itunes.apple.com/us/podcast/houstonian-podcasts/id1163250258?mt=2">Podcasts</a></li>
</ul> </nav>
</div>
</div>
</div>


<div class="row" id="breakingcontainer">
<div class="twelve columns">
<div id="breaking">
<div class="row">
<h3>Breaking News</h3>
<div class="marquee-wrapper">
<div class="marquee" id="marquee">
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/" rel="bookmark">Homecoming Rundown 2017: Welcome to the Circus!</a>
</div>
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/10/14/bearkats-overcome-deficit-defeat-demons-40-36/" rel="bookmark">Bearkats overcome deficit, defeat Demons 40-36</a>
</div>
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/10/13/former-shsu-student-sits-on-death-row-after-losing-appeal/" rel="bookmark">Former SHSU student sits on death row after losing appeal</a>
</div>
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/10/04/former-enron-cfo-cancels-controversial-presentation/" rel="bookmark">Former Enron CFO cancels controversial presentation</a>
</div>
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/09/29/letter-editor-professors-object-fastow-invitation/" rel="bookmark">Letter to the Editor: Professors object Fastow invitation</a>
</div>
<div class="item">
<span class="dot">&bull;</span>
<a href="http://houstonianonline.com/2017/09/20/bearkats-voice-opinions-about-campus-construction/" rel="bookmark">Bearkats voice opinions about campus construction</a>
</div>
</div>
</div>
<a class="close" href="#" onclick="jQuery('#breaking').animate({ height: 0}); return false;"><i class="fa fa-times-circle"></i></a>
</div>
</div>
</div>
</div>


<div class="row">
<div class="twelve columns">
<div id="breadcrumbs">
<ul><li><a href="http://houstonianonline.com">Home</a></li><li><i class="fa fa-angle-right"></i> <a href="http://houstonianonline.com/category/news/" title="News">News</a></li><li><i class="fa fa-angle-right"></i> Homecoming Rundown 2017: Welcome to the Circus!</li></ul> </div>
</div>
</div>


<div role="main"><div class="row">
<section class="nine columns main-container">
<article class="post post-22318 type-post status-publish format-standard has-post-thumbnail hentry category-news tag-featured byline-ethan-horn" id="post-22318">
<div class="imageHolder">
<div class="post-gallery nolink">
<img width="938" height="535" src="http://houstonianonline.com/wp-content/uploads/2017/10/Homecoming-2009-127-938x535.jpg" class="attachment-single size-single wp-post-image" alt="Homecoming-2009-127" />
</div>
<div class="caption"> <span></span></div>
</div>
<div class="post-title">
<aside><a href="http://houstonianonline.com/category/news/" class="boxed" title="News" style="background:#dd3333;">News</a></aside>
<h1>Homecoming Rundown 2017: Welcome to the Circus!</h1>
</div>
<aside class="post-meta">
<ul>
<li>By <strong><a href="http://houstonianonline.com/author/jeh037/" title="Posts by &lt;a href=&quot;http://houstonianonline.com/byline/ethan-horn/&quot; rel=&quot;tag&quot;&gt;Ethan Horn&lt;/a&gt;" rel="author"><a href="http://houstonianonline.com/byline/ethan-horn/" rel="tag">Ethan Horn</a></a></strong></li>
<li>&bull; &nbsp; October 18, 2017</li>
</ul>
</aside>
<div class="post-content">
<aside class="single-meta">
<div class="author">
<img alt='' src='http://0.gravatar.com/avatar/f3736b78621e2860a19ddad0049f1979?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f3736b78621e2860a19ddad0049f1979?s=140&amp;d=mm&amp;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /> <strong><a href="http://houstonianonline.com/author/jeh037/" title="Posts by &lt;a href=&quot;http://houstonianonline.com/byline/ethan-horn/&quot; rel=&quot;tag&quot;&gt;Ethan Horn&lt;/a&gt;" rel="author"><a href="http://houstonianonline.com/byline/ethan-horn/" rel="tag">Ethan Horn</a></a></strong>
<p></p>
</div>
<ul class="meta-list">
<li><a href="http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/#respond" class="postcommentcount"><span class="dsq-postid" data-dsqidentifier="22318 http://houstonianonline.com/?p=22318"><i class="fa fa-comment-o"></i> 0 Comments</span></a></li>
<li><a href="#" onclick="window.print(); return false;"><i class="fa fa-print"></i> Print</a></li>
</ul>
<div class="widget cf widget_tag_cloud">
<h6 class="force">Tags</h6>
<a href="http://houstonianonline.com/tag/featured/" class="tag-link">Featured</a> </div>
</aside> <p>Homecoming is here!</p>
<p>Today marks the first day of festivities for Sam Houston State University’s Homecoming celebration, “Sammy’s Circus”.</p>
<p>The theme was voted on last April as part of the SGA elections, and Bearkats Under the Big Top won by a landslide. Ringmaster Sammy has spent the last few months lining up festivities, and they all kick off tonight.</p>
<p><strong>Events:</strong></p>
<p>The “Sam Jam” Carnival kicks everything off as it has for the past few years. Held at the Holleman Field Complex just off campus. The Carnival kicks off at 7 p.m. and runs until 11 p.m. and will feature rides food and prizes.</p>
<p>“Sam Jam is a newer tradition where students enjoy the carnival nightlife and can witness the announcement of the King and Queen’s Court,” according to Student Activities website, who oversees the event.</p>
<p>Thursday night, the Homecoming Parade will roll through town. The route starts on 19th Street, moves to Sam Houston Ave., then 12th street and finishes on University Avenue. President Hoyt is expected to Marshall the parade in keeping with tradition, and organizations will file in to ride along to Sammy’s Circus. The parade begins at 6:30 p.m.</p>
<p>On Oct. 20, the Program Council will host PC Cinema: Homecoming Edition. The event kicks off at 6 p.m. in the LSC Ballroom, and make sure to grab a valid student ID to get in and grab some free snacks. The specially selected film ties in with the theme, and students will be sure to want to see IT.</p>
<p>Saturday is the big day. Events start early, as an alumni-only coffee will be held on campus for all of our returning Bearkats. For those alum wishing to attend, head over to the John H. Ragsdale Visitor and Alumni Center at 10:30 a.m. for coffee, pastries, and live jazz.</p>
<p>At 1 p.m., tailgating kicks off in Bearkat Alley, just north of Bowers Stadium. Head out to tackle all the booths before the big game.</p>
<p>Also starting at 1 p.m. a volleyball game against Texas A&amp;M Corpus Christi will be played in the Johnson Coliseum, so if tailgating isn’t for you consider cheering on the Bearkats,</p>
<p>SHSU football kicks off against Lamar at 3 p.m. The 5-1 Bearkats are coming home off a comeback win last week against Northwestern State University, and fans will be watching the team as they look to beat the Lamar Cardinals.</p>
<p><strong>King and Queen</strong></p>
<p>Homecoming at Sam has been going on for nearly a century. While the Homecoming Queen has been a staple since the 1920’s, the Homecoming King only dates back to the 1980’s. Together the pair is announced at Sam Jam, a newer addition to the week’s festivities.</p>
<p>To find out about who is running this year, head on over to shsu.edu/homecoming/court.html to read all about them. Voting is conducted through email, and students should have received their ballots Tuesday morning. But hurry Bearkats, voting ends on Oct. 18 at 5 p.m.</p>
<p>However, you choose to celebrate homecoming, remember to be safe and welcome back our alumni.</p>
<div class="post-meta">Last Updated on 18th October, 2017, 12:39 PM</div> </div>
</article>
<div>

<aside id="sharethispost" class="sharethispost cf hide-on-print">
<div class="placeholder"></div>
<a href="#" class="sharenow">Share This Article <i class="fa fa-plus"></i></a>
</aside>


<div class="post post-navi hide-on-print prev"><div class="post-gallery"><img width="200" height="150" src="http://houstonianonline.com/wp-content/uploads/2017/10/ee314787bdb88a4e8ee03d8ca3dfea43c5d2e546.jpg" class="attachment-slider size-slider wp-post-image" alt="ee314787bdb88a4e8ee03d8ca3dfea43c5d2e546" /><div class="overlay"></div></div><div class="post-title"><h2><a href="http://houstonianonline.com/2017/10/18/smmc-hosts-money-saving-seminar-holidays/" title="SMMC Hosts Money Saving Seminar for the Holidays">SMMC Hosts Money Saving Seminar for the Holidays</a></h2></div></div><div class="post post-navi hide-on-print next"><div class="post-gallery"><img width="752" height="535" src="http://houstonianonline.com/wp-content/uploads/2017/10/FullSizeRenderDONE-752x535.jpg" class="attachment-slider size-slider wp-post-image" alt="FullSizeRenderDONE" /><div class="overlay"></div></div><div class="post-title"><h2><a href="http://houstonianonline.com/2017/10/18/professor-struck-university-vehicle-semester/" title="Professor Struck by University Vehicle, Out for Semester">Professor Struck by University Vehicle, Out for...</a></h2></div></div> 
<aside id="endpage-box" class="hide-on-print" style="border-color: #dd3333;">
<a href="#" class="close"><i class="fa fa-times"></i></a>
<aside style="border-color: #dd3333;"><a href="http://houstonianonline.com/category/news/" style="color: #dd3333;">MORE IN News</a></aside>
<h3>Faculty Senate and SGA Updates</h3>
<a href="http://houstonianonline.com/2017/10/11/faculty-senate-sga-updates/" class="btn more-link">READ MORE</a>
</aside>
 
<section id="comments" class="cf">
<div id="disqus_thread">
</div>
<script type="text/javascript">
var disqus_url = 'http://houstonianonline.com/2017/10/18/homecoming-rundown-2017-welcome-circus/';
var disqus_identifier = '22318 http://houstonianonline.com/?p=22318';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'houstonian';
var disqus_title = "Homecoming Rundown 2017: Welcome to the Circus!";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=22318';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</section>

</div>
</section>
<aside class="sidebar three columns single-sidebar">
<div id="fblikebox-6" class="widget cf widget_fblikebox"><h6>Facebook</h6> <div class="like_box">
<iframe src="//www.facebook.com/plugins/likebox.php?href=http://www.facebook.com/houstonianSHSU&amp;colorscheme=light&amp;show_faces=true&amp;stream=false&amp;header=false&amp;height=258" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width: 100% !important; height:258px;" allowTransparency="false"></iframe>
</div>
</div><div id="fblikebox-7" class="widget cf widget_fblikebox"><h6>ADS &#038; DEALS</h6> <div class="like_box">
<iframe src="//www.facebook.com/plugins/likebox.php?href=http://www.facebook.com/houstonianadvertising&amp;colorscheme=light&amp;show_faces=true&amp;stream=false&amp;header=false&amp;height=258" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width: 100% !important; height:258px;" allowTransparency="false"></iframe>
</div>
</div></aside></div>
</div>

<div class="row">
<div class="twelve columns">
<footer id="footer">
<div class="row">
<div class="four columns">
</div>
<div class="four columns">
</div>
<div class="four columns">
</div>
</div>
</footer>
</div>
</div>


<div class="row">
<div class="twelve columns">
<section id="subfooter">
<div class="row">
<div class="four columns">
<p>Copyrıght 2015 The Houstonian. All RIGHTS RESERVED. </p>
</div>
<div class="eight columns">
<ul id="menu-sub-footer" class="menu"><li id="menu-item-6336" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6336"><a href="http://houstonianonline.com/about/">About</a></li>
<li id="menu-item-6333" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6333"><a href="http://houstonianonline.com/current/">Current Issue</a></li>
<li id="menu-item-6335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6335"><a href="http://houstonianonline.com/privacy-policy/">Privacy</a></li>
<li id="menu-item-6334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6334"><a href="http://houstonianonline.com/advertising/">Advertising</a></li>
<li id="menu-item-6337" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6337"><a href="http://houstonianonline.com/contact/">Contact</a></li>
</ul> </div>
</div>
</section>
</div>
</div>

</div> 
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-18563441-4', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script> <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'houstonian';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
<script src="//cdn.goroost.com/roostjs/16128277f9f44de3991ea9ad9eb510da" async></script>
<script>
                var _roost = _roost || [];
                _roost.push( [ 'autoprompt', false ] );
                                    _roost.push( [ 'minvisits', "2" ] );
                            </script>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$("#rotator").cycle({ 
	    fx: 'scrollLeft',
	    timeout: 10000,
	    speed: 3000,
	    pause: 1,
	    fit: 1
	});
});
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/fastclick.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.superfish.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.supersubs.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.flexslider-min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.foundation.plugins.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.owl.carousel.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.magnific-popup.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.marquee.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeajax = {"url":"http:\/\/houstonianonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/app.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/houstonianonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/plugins/wp-cycle/jquery.cycle.all.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.sharrre.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.cookie.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-content/themes/exquisite-wp/assets/js/jquery.endpage-box.min.js'></script>
<script type='text/javascript' src='http://houstonianonline.com/wp-includes/js/wp-embed.min.js'></script>
</body>
</html>
